Mac / PC

Un point sur MacOS Catalina

Vous devez très certainement le savoir si vous êtes de fidèles utilisateurs de Mac, la prochaine version de MacOS arrive à grands pas !

C'est en Octobre prochain (donc quasiment demain), que la version 10.5 de Catalina (le système qi succède donc à Mojave), sortira officiellement sur l'App Store. D'ailleurs toutes les machines commercialisées au de là de cette date, risquent fort d'être motorisées par le dernier rejeton produit par le "Pommier". Mais au delà de ces évidences, il serait bon de se pencher sérieusement sur l'impact d'une telle mise à jour.

* à l'exception de Logic Pro X, tous les autres DAWs du marché ainsi que la très grande majorité des plug-ins tiers qui seront en votre possession, ne seront pas compatibles.

* Les pilotes de périphériques tiers (interface audio, etc), seront aussi à mettre à jour (si leurs éditeurs respectifs ont eu le temps de vous les fournir). Le hardware compatible Class Compliant (donc capable de fonctionner sans pilote), ne sera pas impacté par d'éventuelles incompatibilités.

Catalina ? Un vrai coffre fort !

C'est un point sur lequel les ingénieurs de Cupertino ont sérieusement mis l'accent. On ne compte plus en effet les nombreux malwares et autres logiciels malveillants qui pullulent sur la toile ou sur des sites de cracks. Outre la mise à disposition de correctifs pour combler d'éventuelles failles de sécurité / bugs, Apple s'est voulue beaucoup plus "pro-active" dans ce domaine. Le seul "Hic" dans cette histoire, c'est qu'il signifie que les éditeurs / fabricants vont devoir subir une certaine forme de "marche forcée". En effet, il faudra (en plus de mettre à jour la partie soft / hardware des produits), modifier également les packages d'installation pour que ces derniers ne soient pas tout bonnement "jetés" par le système qui en refusera l'installation. Sans compter que plus globalement (et même si c'était déjà le cas auparavant), votre Mac vous demandera plus fréquemment l'autorisation de faire ceci ou cela (autant dire que vos nerfs vont être mis à rude épreuve). J'imagine bien la chose en pleine session de travail ! :(

On sait pertinemment que les DAWs (peu importe la marque), sont des logiciels qui exécutent en permanence des requêtes vers des bibliothèques / plug-ins divers. Catalina pourrait selon toute vraisemblance prendre ces comportements pour des actes malveillants provenant d'un malware ou de tout autre élément considéré à risque. Autant dire que les problèmes risquent d'être légion quelque soit l'éditeur ou le fabricant dont les produits fonctionnaient déjà sur Mac.

Il semble qu'une procédure de validation ait été mise à place pour que les développeurs puissent soumettre leurs installeurs (Cupertino appelle cela la "Notarisation"). Même si la chose n'est pas obligatoire, il reste fort à parier que pour éviter des soucis de grande ampleur, les éditeurs "se soumettent" à cette "option". Rien ne dit que dans un futur plus ou moins proche, Apple ne finisse pas par imposer une validation systématique des logiciels tiers pour que ces derniers puissent s'installer sur votre Mac ... (c'est dores et déjà le cas pour les applications iPhone et iPad). En théorie, il serait toujours possible néanmoins d'installer des plug-ins non vérifiés par exemple.

En ce qui concerne les pilotes matériels par contre, si ces derniers ne seront pas préalablement vérifiés, ils ne fonctionneront tout simplement pas ! Si vous avez du matériel un peu ancien (mais qui fonctionne encore bien), et que vous souhaitez passez sur Catalina, il vous faudra vous assurer préalablement que son fabricant mette à dispo des pilotes compatibles. Sinon ça sera retour dans la boîte en carton ou passage chez votre revendeur préféré pour remettre la main au portefeuille.

Le 32 bit c'est fini !

Catalina pourrait s'apparenter à une sorte de "grand ménage" ! De nombreuses bibliothèques ont été squizées (même Qkit). Il n'y aura donc plus de support 32 bit dans Catalina, et même les bridge ne fonctionneront plus !

Compatibilité Catalina: es nominés sont ?

à l'heure ou nous écrivons cet article, seulement 2 éditeurs assurent une compatibilité totale avec la 10.15 de MacOS.

* Le premier n'est autre qu'Apple avec Logic Pro X (le contraire aurait été étonnant).
* Presonus annonce la sortie d'une mise à jour de Studio One 4 et des plug-ins associés.

Tous les autres (Native Instruments, etc) ne vous recommandent pas de passer sous Catalina si vous êtes utilisateurs / utilisatrice de leurs produits.

Les développeurs ont du mal à suivre !

C'est un peu la soupe à la grimace pour eux ! La course effrénée aux mises à jour (Mojave n'est même pas encore arrivé à maturité) ne permet pas de stabiliser l'environnement logiciel qui tourne autour de MacOS. On pense dernièrement aux soucis rencontrés par de nombreux fabricants d'interfaces Audio sur MacOS 10.14 sans qu'Apple ait pu à ce jour, être en capacité de corriger (ou presque) définitivement le problème ... :(

Nous aimerions par exemple qu'au lieu de nous pondre un nouvel OS tous les "X" mois, Apple se penche plutôt sur des soucis qui eux impactent sérieusement l'expérience utilisateur de ses clients (je pense au clavier papillon qui doit être certainement le plus gros cauchemar de Cupertino). Bref, nous n'allons pas nous étaler sur des sujets sur lesquels nous avons maintes fois débattus ... Vous connaissez notre point de vue !

Comme à notre habitude, et compte tenu de notre argumentaire, nous ne pouvons que vous recommander la grande prudence. Il y avait bien longtemps que la pomme ne nous avait pas pondu une telle mise à jour (majeure en l’occurrence). Alors ne vous précipitez pas ! Si les sirènes de Catalina étaient plus forte que tout, nous vosu préconisons de faire une image disque / lancer un Time Machine, pour être certain de ne rien perdre dans l'opération. Un utilisateur / Utilisatrice averti en vaut deux ! ;-)

Plus d'infos sur Catalina juste ICI.

BLOG COMMENTS POWERED BY DISQUS